Tunnel HNA mit OpenWrt mit Luci

Aus Freifunk Halle
Wechseln zu: Navigation, Suche

Die Firmware für Deinen Router kannst Du Dir mit dem Meshkit erstellen.

Bitte beachte auch unsere Erläuterung zum Meshkit!

Wir haben dieses mit folgenden Routern erfolgreich getestet.


Der Traffic ins Internet geht über die beiden Gateway-Server.



Konfiguration ab 05.05.2014

1. Die Firmware muss mit unserem Meshkit nach dem 05.05.2014 erstellt wurden sein.

2. Die Openvpn Dateien müssen auf dem Router sein. Diese bekommst du von 3dfx oder kwm und entpackst diese in das Verzeichnis /etc/openvpn/.

3. Auf der Weboberfläche im Administrationsbereich gehst du auf Netzwerk -> Schnittstellen. Bei der Schnittstelle "WAN" auf bearbeiten klicken. Jetzt bei Protokoll auf "halle-dhcp" umstellen, anschließend auf "Wechsle Protokoll" klicken und im Anschluss auf "Speichern & Anwenden".

4. reboot









veraltet (gilt nur für Firmware bis 04.05.2014)

Achtung bitte genau lesen. Fehler machen Deinen Router möglicherweise unerreichbar!

Nach dem diese Dateien entsprechend der Beschreibung angepasst sind, sollte der Router neugestartet werden.


1. In der Datei /etc/config/network ist im Bereich config interface 'wan' die option defaultroute '0' noch einzufügen. Damit alles funktioniert darf bei der Netzwerkschnittstelle WAN kein IPv4 Gateway eingetragen sein.

config interface 'wan'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
 	option proto 'dhcp'
 	option defaultroute '0'

2. Folgende Befehle auf der Konsole des Routers ausführen, um statische Routen zu setzen. x.x.x.x ist durch die IP-Adresse Deines Gateway zu ersetzen.

gateway="x.x.x.x"

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='85.214.81.232'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='178.254.31.83'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='192.53.103.108'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='192.53.103.104'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='128.138.140.44'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='8.8.8.8'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='212.204.49.83'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'

route=$(uci add network route)
uci set network.$route.interface='wan'
uci set network.$route.target='141.1.1.1'
uci set network.$route.netmask='255.255.255.255'
uci set network.$route.gateway=$gateway
uci set network.$route.metric='0'
uci commit


3. Um alle Einstellungen zu übernehmen, den Router neustarten.

reboot